Question for photographers

I have been using the same kit at college since mid September, Nikon D5000 and a Sigma 18-250mm f/3.5-6.3

Now whilst most of my images have been pin sharp and looking good, the past few weeks my lecturer has noticed (and commented at length) that my images haven’t been up to scratch and he knows I can get them sharp because he knows the normal quality of my work.

I haven’t dropped either the camera or the lens. I have never cleaned the censor myself as I’m paranoid I’ll damage it. No one else has been using my gear.  I’m at a loss as to what’s causing this, and since I have my final images to shoot soon I am really worried they wont be good enough to pass!

Any suggestions?

While I’ve been sat here writing this there is only one possible change that I can think of.  I have added a UV filter to my lens about a month ago.  Could that be it?

Advertisements

2 thoughts on “Question for photographers

  1. I would lean towards thinking that your settings on your camera are the culprit. My suggestion would be to reset the camera to factory settings and start over again.

    Like

    • Thank you for the response ☺️
      The problem has since been solved but the solution raised its own questions. The filter was indeed the problem, and every shot since (more or less) has been pin sharp as long as I have no filter on the lens. Neither myself or my lecturer can figure out why though.

      Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s